QoS component item ID in Performance Management data exports keep changing
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QoS component item ID in Performance Management data exports keep changing

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Article ID: 189652

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Exporting QoS data from Performance Management duplicate items and constantly changing ItemID values are present.

Also many of the item names have meaningless names such as:

  • Name=cbQoS Interface UnknowncbInterfaceNameIndex-General_Computing-Video-Ports-IN
  • Name=cbQoS Interface UnknowncbInterfaceNameIndex-General_Computing-VLAN-QoS-IN

Environment

Release : 3.7

Component : IM Reporting / Admin / Configuration

Cause

Incomplete data in device MIB OIDs.

This attribute is read from the MIB data to align the QoS Policy to an Interface.

  • cbQosServicePolicyIfIndexValue 1.3.6.1.4.1.9.9.166.1.1.1.1.4

Here is a sample from the discovery logging for a problematic QoS item:

  • SnmpResponseVariable [oid=1.3.6.1.4.1.9.9.166.1.1.1.1.4, type=INTEGER, value={158,285,0,0,0,0,0,0,0,0,0,0}, isDelta=false, isList=true, error=SUCCESS, isDynamicIndex=false, indexList=[2528, 4560, 938063732, 946051204, 1596288068, 2007019540, 2015009188, 2275462948, 2275462996, 2401614260, 3093483828, 4175035188]]

Taking an index from the devices polling configuration as a sample, we'll use 2275462948.

If we look at the value for index 2275462948 we see it's 0. This shows us that it has no interface assigned.

Resolution

We need the SNMP agent to tell us what the correct interface that aligns to a given classmap. Without that we see the issue observed here.

Consult the device administrator and/or vendor to determine a cause and solution.