After installing CA API Gateway Patch or Hotfix the gateway won't start
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After installing CA API Gateway Patch or Hotfix the gateway won't start

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Article ID: 189634

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Updated On:

Products

CA API Gateway API SECURITY CA API Gateway Precision API Monitoring Module for API Gateway (Layer 7) CA API Gateway Enterprise Service Manager (Layer 7) STARTER PACK-7 CA Microgateway

Issue/Introduction

When you run a gateway patch or a hotfix on the gateway you get the error failed dependencies and the gateway status shows WONT_START

For e.g:

# rpm -Uvh ./ssg-appliance-9.1.01-7043_hotfix_DE440811.x86_64.rpm
error: Failed dependencies:
        ssg >= 9.1.01 is needed by ssg-appliance-9.1.01-7043_hotfix_DE440811.x86_64

Try to run the same again and the following happens:

# rpm -Uvh ./ssg-appliance-9.1.01-7043_hotfix_DE440811.x86_64.rpm
Preparing...                ########################################### [100%]
   1:ssg-appliance          ########################################### [100%]

Accessing configuration, please wait ...

----------------------------------------------------------------------
SecureSpan Gateway Status
----------------------------------------------------------------------

Configuration:
    Node Status = WONT_START
    Node Status Timestamp = 2020-04-27 08:35:21
    Node Status Since = 2020-04-27 08:35:21

Press [Enter] to continue.
CA API Gateway status options:

 1) Start the CA API Gateway
 X) Exit menu

Please make a selection: 1
Node start failed due to 'default could not be started: Node couldn't be started last time it was attempted; the PC will retry soon'.

Environment

Release : 9.1

Component : API GATEWAY

Cause

The above patch needs a 9.1.01 gateway but when if you check the database for the SSG version, it shows 9.1.00

mysql> SELECT * FROM ssg_version;
+-----------------+
| current_version |
+-----------------+
| 9.1.00          |
+-----------------+
            1 row in set (0.00 sec)

You can also check this from the SSG menu:

Welcome to the CA API Gateway - 9.1.01
running on Red Hat Enterprise Linux Server release 6.9 (Santiago)
 
This user account allows you to configure the appliance
What would you like to do?
 
1) Configure system settings
2) Display CA API Gateway configuration menu
3) Use a privileged shell (root)
4) Change the Master Passphrase
5) Display Remote Management configuration menu
6) Manage HSM
7) Display CA API Gateway Enterprise Service Manager configuration menu
8) Display Patch Management menu
9) Display Log Viewing menu
    1. R) Reboot the CA API Gateway appliance (apply the new configuration)
    2. X) Exit (no reboot)
 
Please make a selection: 2
This menu allows you to configure the CA API Gateway application
What would you like to do?
 
1) Upgrade the CA API Gateway database
2) Create a new CA API Gateway database
3) Configure the CA API Gateway
4) Change the CA API Gateway cluster passphrase
5) Delete the CA API Gateway
6) Display the current CA API Gateway configuration
7) Manage CA API Gateway status
8) Reset Admin password
X) Exit menu
 
Please make a selection: 1
Gateway Database Upgrader.
Enter 'quit' to exit at any time.

 Database upgrade is required.
 Software version : 9.1.01
Database version : 9.1.00
 
Perform upgrade? [No]:

 

Resolution

1. Upgrade the DB via the SSG menu so that the SSG versions match.
2. Restart the gateway services. 

Additional Information

The above error could occur in other higher versions of the gateway too. 
Please make sure the software and the database versions of the gateway match and before applying a patch, please check the pre-requisites from the below link:
https://techdocs.broadcom.com/us/product-content/recommended-reading/technical-document-index/ca-api-gateway-solutions-and-patches.html