Data is no longer present after editing Vendor Certification in CA Performance Management (CAPM)
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Data is no longer present after editing Vendor Certification in CA Performance Management (CAPM)

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Article ID: 189522

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

The Data Collectors are no longer collecting data.  The system status indicates all green bur when clicking on any link it says 'No Data To Display'.

Interfaces are all missing data.

Environment

All supported Performance Management releases

Cause

Vendor Certification metrics edited through the Performance Management Vendor Certification Edit UI.

This is found in the UI via Administration -> Monitored Items Management -> Monitoring Profiles. Select the Vendor Certifications entry on the left under Monitoring Configuration.

Choose a Vendor Certification. Choose a Metric. Choose the Edit button.

Saving that creates a Certification file in (default path) named after the Vendor Certification that was edited:

/opt/IMDataAggregator/data/certifications/custom/vendor_certs

The presence of that file breaks the default Certification which is expecting edits to arrive via the available and recommended Certification extensions functionality.

Resolution

Delete the offending file from (default path):

/opt/IMDataAggregator/data/certifications/custom/vendor_certs


Restart the Data Aggregator. Instructions for doing so in various environmental configurations is covered in the following Knowledge Base article.

Additional Information

Extend Metric Families. This is where a new metric would be added, or a change made to an existing metric, at the Metric Family level.

Same for Vendor Certifications.