search cancel

Which versions of the ca_apm_probe can be used with the NodeJS Collector Agent?

book

Article ID: 189458

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

In order to monitor NodeJS 12.x the ca_apm_probe should be at 10.8.82 release at the minimum. Can this ca_apm_probe (10.8.82 or later) be used with any version of the NodeJS Collector Anget (eg: NodeJs Collector Agent 10.5) to monitor NodeJS application? 

Environment

APM 10.5.x onwards

Resolution

Any version of ca_apm_probe can be used with any version of the NodeJs Collector agent, for example the ca_apm_probe.10.8.x will run with NodeJS Collector Agent 10.5.x, however not all extensions/probe provided by ca_apm_probe.10.8.x would be supported on NodeJS Collector Agent 10.5.x.  

Additional Information

To download the ca_apm_probes go to below link:
https://www.npmjs.com/package/ca-apm-probe