TDM: Download button not working after new patch TDMWeb-4.8.195.0, upgrade
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Article ID: 189423
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Updated On:
Products
CA Test Data Manager (Data Finder / Grid Tools)
Issue/Introduction
We found an issue after upgrading TDMWeb-4.8.195.0, The download icon is not working in Submitted Requests of TDM portal.
Can you check with your SE? Without fixing this we can't move this patch to our TDM Production.
We verified in Internet explorer , found same issue.
Environment
Release : 4.8
Component : CA Test Data Manager
Cause
We are unable to reproduce this issue in house, therefore we believe the problem is due to something that changed in the user's environment.
Resolution
Engineering went through the recording and the TDM Logs you provided. The TDMJobEngine.log shows "Not a valid Location: " E:\Dev\ZRD\Logs\CA\CA Test Data Manager Portal\Jobs\CUSTOM\PJ21859.zip", while the TDMAppDataLocation shows "E:\Program Files\CA\CA Test Data Manager Portal". Both locations are different, and my understanding from Engineering is the given property value should point to the same location.
Check the application.properties file, and verify these are set properly: tdmweb.publish.folder- this property used to save the published artifact. tdmweb.appdata.folder- this property used to cross verify the artifact location.
Issue is resolved after correcting the CATDMWEB_APPDATA Environment variable to artifact location.