Event Manager logs filling disk at rapid rate and sync errors in the EM log
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Event Manager logs filling disk at rapid rate and sync errors in the EM log

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Article ID: 189384

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Updated On:

Products

CA Performance Management Network Observability

Issue/Introduction

Upgrade from 23.3.12 to 24.3.7 and now in Wrapper.log there is a error message:

INFO   | jvm 1    | 2025/03/30 00:00:00 | --------------------------------------
INFO   | jvm 1    | 2025/03/30 00:00:00 | ERROR | qtp1721340629-64273      | 2025-03-30 00:00:00,543 | com.ca.im.portal.em.util.NPCEventManagerWSImpl
INFO   | jvm 1    | 2025/03/30 00:00:00 |       | https://<IP_hostname>:8582/EventProducerWS: Unsynced datasource attempted to push events to EM. Event data is:
INFO   | jvm 1    | 2025/03/30 00:00:00 | ERROR | qtp1721340629-64273      | 2025-03-30 00:00:00,543 | com.ca.im.portal.em.util.NPCEventManagerWSImpl
INFO   | jvm 1    | 2025/03/30 00:00:00 |       | Event received
INFO   | jvm 1    | 2025/03/30 00:00:00 |   ProducerID: 3
INFO   | jvm 1    | 2025/03/30 00:00:00 |   LocalID: 1f9bcd74-8874-40f3-97c3-539b001216c0

 

and the wrapper log is about 23GB per day

Environment

Performance Management : any supported release

Cause

Event Manager is not registered with the Data Aggregator

Resolution

  1. Stop and restart the Event Manager process on the Performance Center system
   systemctl stop caperfcenter_eventmanager

  systemctl start caperfcenter_eventmanager
  1. Do a full sync of the Event Manager data source.

 

Additional Information