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Admin console can't display the latest Riskminder and Authminder instances

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Article ID: 189337

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Updated On:

Products

CA Advanced Authentication - Strong Authentication (AuthMinder / WebFort) CA Strong Authentication CA Rapid App Security CA Risk Authentication CA Advanced Authentication

Issue/Introduction

 

After the upgrade, I can login to admin console using masteradmin user successfully.  However, I found two things unexpected. 

1, Under "Service and Server Configurations" -> "Strong Authentication" -> "Instance Management" , I could still see the 9.0 version instance there but not the 9.1 ones.

2, Under "Service and Server Configurations" -> "Risk Authentication" -> "Instance Management", I could see the warning message "

Environment

Release : 9.1

Component : AuthMinder(Arcot WebFort)

Cause

The reason is that there are old instances in the DB that are no longer in use.

Resolution

Follow the procedure below to delete the old instance.


01.  Stop AA service

02. run the following sql in DB.
delete from arrfinstances;
delete from arwfinstances;
delete from arrfprotocolregistry where instanceid != 'DEFAULTID';
delete from arwfprotocolconfiguration where instanceid != 'DefaultInstance';
commit;

03. restart service.