After 4/9/15 upgrade, Cannot connect to Oracle datbases to mask
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After 4/9/15 upgrade, Cannot connect to Oracle datbases to mask

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Article ID: 189267

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

We upgraded to 4.9.15 last week for issue with JSON columns and now we cannot connect to Oracle databases


2020-04-20 13:37:08.249 Database service has not started 

2020-04-20 13:37:08.250 or supplied connection parameters are incorrect: D:/IO/TDM/RIW/DB/CONNECTIONS/connect_ora_gmcosru_finlea_uat.txt 

2020-04-20 13:37:08.251 exit value = 1 


Environment

Release : 4.9

Component : CA Test Data Manager

Cause

Looking at the masking job log, we see the connection attempt failing.

2020-04-20 13:37:07.935 attempting to connect 
2020-04-20 13:37:07.938 Using URL:jdbc:oracle:thin:@//<hostname>.<domain.com>:1531/<account_name> 
2020-04-20 13:37:08.056 Connecting with driver: oracle.jdbc.driver.OracleDriver using URL: jdbc:oracle:thin:@//<hostname>.<domain.com>:1531/<account_name>
2020-04-20 13:37:08.249 Database service has not started 
2020-04-20 13:37:08.250 or supplied connection parameters are incorrect: D:/IO/TDM/RIW/DB/CONNECTIONS/connect_ora_account_name_finlea_uat.txt 
2020-04-20 13:37:08.251 exit value = 1

Resolution

This has been addressed in FastDataMasker-4.9.18.0. If you are having trouble getting FDM to connect to Oracle, please contact Support and request the latest release of FDM.