search cancel

Oracle 19c and APM 10.7 Compatibility.

book

Article ID: 189263

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

Is APM version compatible with Oracle 19c? Our database team will be upgrading our APM DB this year.  So I would like to know if there would be any issues.

 

 

Environment

Release : 10.7.0

Component : APM Database

Resolution

Oracle 19c and APM 10.7 is now certified with one use case only.

That use case is limited to customers having APM 10.7 install already and the existing version of Oracle is upgraded to 19c by the customer themselves. No issues are observed when testing.  This should have no impact on APM and this use case only will be supported by Support.

Additional Information

The database schema cannot be created by the APM installer - it is hard-coded and checks for Oracle versions 11 or 12.  If it detects 19, it writes out an error message about an incompatible database version and fails, both interactive and silent installations.