AWA: Unable to start CP and WP processes, error in the logs "U00003531 UCUDB: Error while checking data source (e.g. code conversion or driver problem, see log file)."
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AWA: Unable to start CP and WP processes, error in the logs "U00003531 UCUDB: Error while checking data source (e.g. code conversion or driver problem, see log file)."

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Article ID: 189236

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Symptoms of the issue:
When starting Automation Engine, CP and WP processes do not start. In the Automation Log files, you see the following errors:
U00003531 UCUDB: Error while checking data source (e.g. code conversion or driver problem, see log file).
U00003594 UCUDB Ret: '3531' opcode: 'OPEN' SQL Stmnt: ''
U00003611 DB OPEN executed. Return Code = '0000003531'
U00003620 Routine 'UCMAIN_R' forces trace because of error.
U00003449 Output to the TRACE file is finished.

In the forced trace file, you may see the messages such as presented below:

U00003611 DB OPEN executed. Return Code = '1017'
U00003590 UCUDB - DB error: '72000', 'ORA-01017: invalid username/password; logon denied', '1017', 'java.sql.SQLException'
U00032031 Error when connecting to Database

Environment

Release : 12.1, 12.2, 12.3

Component : AUTOMATION ENGINE

Cause

Automation Engine cannot connect to the database due to misconfiguration

Resolution

Automation Engine could not connect to the database as ORA-01017 (Oracle error) states.

In most of the cases the issue is with one or a combination of the following:

1. ucsRV.INI Database configuration string (Database name, password, character set, syntax, etc.)
2. Configuration on the server side depending on the database type. For example, for Oracle Databases, verify ORACLE_SID and LD_LIBRARY_PATH. 
3. Verify there is no issue with network between the Automation Engine and database servers. 

Verify all the items listed above. If all the configuration is correct, open a case with Broadcom Support.