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No response error retrieving snmpv3 engine ID from CA Performance Center

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Article ID: 189170

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

No response error retrieving snmpv3 engine ID from CA Performance Center.

I tried this http://<pc_host>:<event_manager_port>/EventManager/webservice/notifications/engineId

Environment

Release : 3.7, 20.2, 21.2

Component : IM Reporting / Admin / Configuration

Cause

Something is blocking access to the Event Manager port from your location

Resolution

To get Get the SNMPengineID

The trap receiver (for example, CA Spectrum), using SNMPv3, uses the SNMPengineID to allow encrypted traps from a specific sender for decryption. Use the following REST endpoint to get the SNMPengineID:

URL:http://<pc_host>:<port>/EventManager/webservice/notifications/engineId

port is the port for the Event Manager.
Default: 8281

Method: GET

If you can't access this port, try from localhost on the CA Performance Center (CAPC) server itself:

wget -qO - http://127.0.0.1:8281/EventManager/webservice/notifications/engineId

You should have wget already installed on CAPC as it is a prerequisite

Note that if you are on 20.2.1 or later, you would need to provide the admin user and admin user password as credentials for the REST call/wget command.

Adding the username/password to wget:

wget -user admin --ask-password -qO - http://127.0.0.1:8281/EventManager/webservice/notifications/engineId

This will prompt for the admin user password when run.