Import failed when endpoint unchecked
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Import failed when endpoint unchecked

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Article ID: 189157

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

During the import process an error message is received:
ERROR [com.eurekify.businessflow.logic.tasks.SingleImportTaskLogic] (taskExecuteServiceContainer-6) Connector 'UNIVERSE_NAME-CA IdentityMinder[ENDPOINT_NAME]ENDPOINT_TYPE[EP]Linux HOSTNAME' was not selected to run, but have no last known good configuration. Import will FAIL! (Universe: UNIVERSE_NAME)

Followed by

ERROR [com.eurekify.businessflow.logic.tasks.SingleImportTaskLogic] (taskExecuteServiceContainer-6) Connector 'UNIVERSE_NAME-CA IdentityMinder[ENDPOINT_NAME]ENDPOINT_TYPE[EP]Linux HOSTNAME' was not selected to run, but have no last known good configuration. Import will FAIL! (Universe: UNIVERSE_NAME)

Environment

Release : 14.2

Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)

Cause

A connector did not run or failed to be connected to

Resolution

When an import is done, we cannot fully perform the import without all the information from all the accounts and connectors.
Some data may depend on each other and the user accounts are not compete without the data from all accounts.

However, some endpoints are not online, or have connectivity issues or simply the administrator decides not to run them for any number of reasons.

Each time a connector is finished successfully a "Last Known Good Configuration" is created. If the connector is not running for any reason the LKGC (Last Known good Configuration) is used instead of the connector data.

If there is no LKGC from a connector the import process cannot complete successfully.
If the endpoints never finished successfully so there is no LKGC and the import may fail as the data is not complete.