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Refresh cache does not work after uploading untrusted ip

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Article ID: 189056

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Updated On:

Products

CA Advanced Authentication - Strong Authentication (AuthMinder / WebFort) CA Strong Authentication CA Rapid App Security CA Risk Authentication CA Advanced Authentication

Issue/Introduction

using an org administrator account. uploaded a untrusted ip file with append method successfully. Then I migrated production successfully. After that I refresh system cache to make it work.

After refreshing cache, the web service suddenly does provide any suggestion like below.

                <rf11:matchedRuleMnemonic></rf11:matchedRuleMnemonic>
                <rf11:ruleAnnotation></rf11:ruleAnnotation>
 

 

Why?

Cause

There is an error that happens on riskminder instance that we don't use it anymore. 
How to remove the old riskminder instance?

Environment

Release : 9.1

Component : RiskMinder(Arcot RiskFort)

Resolution

01. Stop AA service

02. run the following sql in DB.
delete from arrfinstances;
delete from arwfinstances;
delete from arrfprotocolregistry where instanceid != 'DEFAULTID';
delete from arwfprotocolconfiguration where instanceid != 'DefaultInstance';
commit;

03. restart service.