search cancel

Vertica message Epoch number must be between…

book

Article ID: 189012

calendar_today

Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

After HW crash the DB won't start, appears to be corrupted.

No backups exists to use in restoration efforts.

Tried to restore from last good epoch and receive the message “Epoch number must be between…”
https://knowledge.broadcom.com/external/article?articleId=37369


Messages:
Recover:7fcbe3fff700 [Recover] <WARNING> Aborting recovery: Invalid recover epoch=0xbe6fde, less than AHM epoch=0xbe7007
Recover:7fcbe3fff700 [Init] <INFO> Startup [Plan Recovery] Invalid recovery epoch 12480478 <  AHM 12480519

Cause

Vertica table corrupted

Environment

PM 3.7

Resolution

Please contact Broadcom Support for further assistance with this issue.