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Search button on VSI transactions window is not working properly

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Article ID: 189004

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Updated On:

Products

CA Cloud Test Mobile CA Application Test

Issue/Introduction

Search button on VSI transactions window is not working properly when followed the below steps:

. Open a VSI file with more than one translations.

. Search with transaction id in the VSI -->Find as in the below screenshot.

Some time gets the message "Nothing was found to that contains search text" as in the below screenshot.

Cause

The issue is happening when the searched transaction id is above the transaction id in the VSI transaction list.

Environment

Release : 10.5

Component : CA Service Virtualization

Resolution

By design, the search functionality in VSI goes from Top to Bottom and when trying to find something above the selected transaction causes the issue. When selecting the first transaction in the VSI and perform search, it should work.

For example, see the below screenshot. I selected Transaction 179 in VSI and I searched for 173 which is above 179 and I get the error you reported.


Look at the below screenshot, where I do a search on 185 instead of 173 and transaction is found.


By design, VSI search is from Top to Bottom when finding transactions and the same behavior is applied here.

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