CAS9/CAIRIM received S306 after CA Datacom upgrade
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CAS9/CAIRIM received S306 after CA Datacom upgrade

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Article ID: 188923

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Updated On:

Products

Datacom Datacom/DB Datacom/AD

Issue/Introduction

After upgrading CA Datacom/AD, our CAS9 proc fails with an S306. The error is listed below:

PRODUCT(CA DATACOM) VERSION(BD15) INIT(DBCR5PR) LOADLIB(MY.DATACOM.LOADLIB) PARM(PC=PROD,PCC=DBPCCPR)

 00.58.38 STC08270  CAS9115I - INPUT: PRODUCT(CADATACOM) VERSION(BD15) INIT(DBCR5PR) LOADLIB(...

 00.58.38 STC08270  CSV019I REQUESTED MODULE DBCR5PR  NOT ACCESSED, IS IN NON-APF LIBRARY/CONCATENATION

 00.58.38 STC08270  CSV028I ABEND306-0C  JOBNAME=CAS9      STEPNAME=CAIRIM

 00.58.38 STC08270  IDI0123S Processing of abend S306 terminated due to unsupported execution environment: TCB Not protect KEY 8 o

 00.58.38 STC08270  IEA995I SYMPTOM DUMP OUTPUT  302

    302             SYSTEM COMPLETION CODE=306  REASON CODE=0000000C

    302              TIME=00.58.38  SEQ=00008  CPU=0000  ASID=0045

    302              PSW AT TIME OF ERROR  070C1000   81421B5A  ILC 2  INTC 0D

Environment

Release : 15.1

Release : 15.0

Component : CA Datacom/AD

Component : CA Datacom/DB

Cause

The S306 indicates that one of the loadlibs in your CAS9 STEPLIB or on the CAIRIM LOADLIB() statement for CA Datacom is not APF authorized correctly.

Resolution

Please review your APF settings, and be sure that all of the STEPLIB files are correctly listed in the APF configuration, and that they are on the Volume that is specified to APF. In addition, verify that the file from your LOADLIB() statement is defined correctly with the correct volume.

As noted in the AXRIM01 job:

The COMMON SERVICES TARGET library and CA Datacom TARGET LIBRARY must both be APF-AUTHORIZED before submitting this member. If either one or both are not APF-AUTHORIZED, the JOB will fail with an ABEND306-0C error.

This error comes from the operating system, and not from the CA Datacom program. If you have CA SYSVIEW, please issue the APFLIST command, then do a Find on your CA Datacom/AD and your CA Common Services DSNs. Enter VER as a line command beside each to be sure it is found where it is specified.

Additional Information

As always, please contact Broadcom support for CA Datacom if you have further questions.