Error: "No such mount exists" in a DLP discover scan
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Error: "No such mount exists" in a DLP discover scan

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Article ID: 188897

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Updated On:

Products

Data Loss Prevention Network Discover Data Loss Prevention

Issue/Introduction

A scan of a network share in Symantec Data Loss Prevention (DLP) fails with the error "No such mount exists -- <drive letter>:."

Environment

Release: 15.x or 16.x

Component: DLP Network Discover on Windows 

Cause

The listed drive is not available, or is mounted for a particular purpose for example for CD/DVD on Network Discover server. This can be verified on Windows Disk Management.

Resolution


On the Network Discover server update the Crawler.properties file by removing the conflicting drive letter from the list of valid drive letters in the following setting:
 
# All valid drive letters to be used for mounting on windows
filesystemcrawler.mount.drive.validletters.windows = l:,m:,n:,o:,p:,q:,r:,s:,t:,u:,v:,w:,x:,y:,z:

Restart SymantecDLPDetectionServerService service.

The Crawler.properties file, by default, is located in these paths:
WIndows: C:\Program Files\Symantec\DataLossPrevention\EnforceServer\<version>\Protect\config
Linux: /opt/Symantec/DataLossPrevention/EnforceServer/<version>/Protect/config

In one instance, the steps above did not resolve the issue.
After removing the drive letter, the error repeated with another drive letter.
This was resolved by restarting the file share host server.

 

Additional Information

The drive letters in the "filesystemcrawler.mount.drive.validletters.windows" line are the hard coded letters that our server will assign to the remote share when the scan starts.
If that drive letter is already in use, you will see the "No such mount exists" error.
Removing that drive letter from the Crawler.properties file will prevent our scans from trying to assign that letter during any subsequent scans.

If not enough mount points are available, or to avoid this error entirely, DLP does support using JCIFS which mounts the shares outside of normal windows mount points.
To enable JCIFS scanning, modify the Crawler.properties:

Set "filesystemcrawler.use.jcifs" to true.

If there is concern about sending the password in plain text, ensure that "jcifs.smb.client.disablePlainTextPasswords=true" is set in the jcifs.properties file located in the same "config" directory as shown above.