"Error running initdb.exe" when installing Jasper Reports
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Article ID: 188762
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Updated On:
Products
CA Service Management - Service Desk Manager
Issue/Introduction
When attempting to install Jasper Reports, the following error occurs:
The install.log shows the error bellow:
Initializing database Executing initdb.exe -U postgres -E UTF8 -D "C:/JASPER~1/JASPER~1.0/POSTGR~1/data" Script exit code: 1 Script output: Script stderr: Program ended with an error exit code Error running initdb.exe -U postgres -E UTF8 -D "C:/JASPER~1/JASPER~1.0/POSTGR~1/data": Program ended with an error exit code Executing sc stop "" Script exit code: 123 Script output: [SC] OpenService ERROR 123:
Environment
Release : 7.2
Component : JASPERSOFT REPORTS FOR SERVICE MANAGEMENT
Cause
This error is usually a result of the system environment issue.
Resolution
Check the following: 1. Log in as local admin to install. Make sure that the user has full rights to the folder indicated in the error trace.
2. Check and make sure that the postgresql port 5432 is available. Try netstat -a to check which ports are being used.
3. Go to Control Panel -> System and Security ->Administrative Tools->Services and make sure that there are no reminant postgresql processes running using the same port.
4. Check, UAC and/or firewall may be preventing initdb.exe to run. Try turning them off temporarily to see if that is the case.