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AutoProbe.log with repeated entries

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Article ID: 188754

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Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

The AutoProbe log is growing continuously, causing out of disk errors.
 At the end of the log the same class is instrumented repeatedly

Smart instrumentation and dynamic instrumentation are already disabled

The last tip was to disable introscope.agent.deep.entrypoint.enabled and restart the process.

However the .profile already has introscope.agent.deep.entrypoint.enabled at false...


 

Cause

The instrumented code is being updated continuously with a new timestamp in the filesystem.

If the classes are updating continuously, the agent will continue to process these as expected.

There is no configuration to stop the agent instrumenting classes updated in this way.


This dynamic updating of classes is from application side.



 

Environment

Release : 10.7.0

Component : APM Agents

Resolution

The only suggestion is to limit the log file size using a JVM parameter

     

     -Dcom.wily.autoprobe.logSizeInKB=10000

Additional Information

More details about the parameter to limit log size

https://knowledge.broadcom.com/external/article?articleId=11047