nas - how to setup notifications via email or SMS
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nas - how to setup notifications via email or SMS

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Article ID: 188730

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Updated On: 09-13-2023

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Is there a way to setup notifications via email or SMS to different engineering groups.  We have multiple engineering groups and some of the devices are on one hub so is there a way to split the notifications between engineering groups? I have read over the NAS probe and didn't see how to set this up by OS.

Environment

Release : Any supported UIM release

Component : UIM NAS

Cause

- configuration for alerting

Resolution

Options for sending alarms via email/SMS to one or more recipients

- You can setup emailgtw profiles, e.g., group profile addresses. (multiple recipients must be comma separated)
- You can use an email distribution list (DL)
- In the nas AutoOperator (AO) EMAIL profile you can configure a single email address or multiple email addresses separated by commas

Helpful References


Creating or Editing a Profile (nas)

Create a Profile (emailgtw)

emailgtw IM Configuration

Warning: if you're using a distribution list, make sure there is no restriction on the DL on who can send to it. You'll have to check with your SMTP administrator to remove any restriction if that is the case. The SMTP / Exchange server administrator can tell if the email is received / or not being sent to the DL. 

SMS
If you would like to include a recipient's mobile phone and send an SMS message you can simply use the correct address for the service provider, here is an example of a Verizon phone address:
e.g., xxx-xxx-xxxx@vtext.com

Additional Information

Create an emailgtw profile for the desired <group>@xxx.xxx,

Sent a test message via the nas that kicks off an EMAIL action (based on the nas AO profile), and the email should be sent and received.

You can use nas AO profile modifications for filtering the messages and sending them to different groups.

If required, User Tags can be used to identify Windows versus UNIX/Linux systems so the values can be used to filter the messages and send them to the appropriate groups.

See also:
https://knowledge.broadcom.com/external/article?articleId=113769

Also the modification of user tags does not automatically get updated in USM until the robot is restarted.  The following is an example:

You must first open the controller probe UI and click on the Misc. tab.  Modify User tag 1 and/or User tag 2 for your purposes.
Even through Applying the changes in the controller probe warns that the robot will be restarted, the robot will need to be manually restarted once again for the user tag modifications to show automatically in OC.
Once the robot completely comes online once again, open USM and navigate to the robot in question.  You will now see that the user tag information has been updated.

***If OC is already opened, then you will need to refresh the browser for the changes to show correctly.***