Getting error "ACS_FAILED_PROCESS_FAILURE"
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Getting error "ACS_FAILED_PROCESS_FAILURE"

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Article ID: 188681

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) SITEMINDER

Issue/Introduction

SiteMinder is Service Provider and receives SAML Assertion but throws HTTP 500.


HTTP Status 500 - Internal Error occured while trying to process the request. Transaction ID: <Transaction ID> failed.

affwebserv.log reports "ACS_FAILED_PROCESS_FAILURE"

How can we fix this ?

Environment

All versions of SiteMinder

Cause

"ACS_FAILED_PROCESS_FAILURE" means the Assertion is Rejected.

 

There can be few reasons why an Assertion can be rejected.

1. Assertion was signature does not verify or missing.
2. Assertion validity issue. (IssueInstance is earlier than OnOrBefore, or later than NotOnOrAfter timestamp even with the Skew Time)

 

 

Resolution

For any reason if the Assertion is Rejected then there is no user credential to attempt an Authentication at the Service Provider.

As a result Policy Server will return "Authentication Attempt Failed" with AuthReason=50.

This will be HTTP 500 at the browser unless a Server Redirect URL is defined.