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In SDM 17.3 GA Auto Close is not working.

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Article ID: 188652

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

Steps:
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1. Install SDM 17.3 or upgrade to 17.3.
2. Enable Auto Close by going to Administration -> Service Desk -> Application Data -> Codes -> Auto Close settings.
3. Create few Incidents and change status to Resolve.
4. After mentioned Auto close time the ticket status does not change to Close and stays in Resolved status only.

In logs below errors are seen:

04/07 19:38:27.32 ibtest domsrvr                 2940 ERROR        top_ob.c              4031 Got msg with type set to 0
04/07 19:38:27.33 ibtest spelsrvr               11692 ERROR        cr.spl                8851 Unable to schedule auto-closure for ticket: cr:400002 - INVALID
04/07 19:39:07.97 ibtest domsrvr                 2940 ERROR        top_ob.c              4031 Got msg with type set to 0
04/07 19:39:07.98 ibtest spelsrvr               11692 ERROR        cr.spl                8851 Unable to schedule auto-closure for ticket: cr:400004 - INVALID

Cause

This is a known defect (DE54332) fixed in 17.3 RU 1 and later Rollup versions.

Environment

Release : 17.3

Component : SERVICE DESK MANAGER

Resolution

Upgrade to the latest 17.3 Rollup version. 

Refer to: CA Service Management Solutions & Patches