Package Server is not able to provide codebases. Getting message: "Package server is unable to provide any codebases with current configuration."
book
Article ID: 188459
calendar_today
Updated On:
Products
IT Management SuiteClient Management Suite
Issue/Introduction
Some Package Servers are not able to serve packages to their assigned client machines per their Site configuration. The packages were either ready or downloading them.
The Symantec Management Agent UI showed the following message when trying to refresh the packages:
"Package Server does not provide any codebase.
Package server is unable to provide any codebases with current configuration. Please check the Package Server configuration and logs for possible errors."
Under the Package Server tab for those Package Servers with the message above, it showed "Codebase: None
Environment
ITMS 8.1 and later
Cause
In this particular scenario, the customer had configured under Site Server Settings these package servers to only provide HTTPS codebase. UNC and HTTP were off.
On those package servers, in the IIS manager, there was a binding for port 443 but no certificate was assigned to it.
In order for the Package Server agent to provide the proper codebase references, IIS needs to be configured with the necessary references.
In this case, assigning the proper certificate fixed the issue.
Resolution
If only HTTPS codebases are setup to be provided, make sure the binding for port 443 has a valid certificate in IIS Manager for the Site Server.
Also, check that IIS services are able to start without getting errors on dependencies.