search cancel

mysql probe fails to start on linux robot and throws max restarts

book

Article ID: 188415

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) Unified Infrastructure Management for Mainframe CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

mysql probe fails to start on linux robot and produces "max restarts" error in controller log.

(Example: "Controller: Max. restarts reached for probe 'mysql' (command = mysql)").

The probe may even turn green in Infrastructure Manager, but not get a port or pid and eventually turns red error state.

Environment

Release : 9.2.0+

Component : UIM MYSQL 1.51 T1/ 1.51 or higher

Cause

Determined there was a missing shared library rpm package (such as: compat-libstdc++)
(Note - Some recent Linux distributions come with newer versions of the C++ libraries and some probes depend on older libraries or updated libraries).

Resolution

Please take the following steps to determine if this is the issue and see what package the probe is looking for:

1. De-activate mysql probe.

2. On the Linux machine, go to the probe mysql folder on the system and provide the output of the following ldd command:

 ldd  mysql_monitor



In this instance, this is the missing library:

   libstdc++.so.5 => not found

3.Research the particular version for your particular Linux version to find a correct install command:

Example:
# yum install compat-libstdc++-[particular version... such as 33.x86_64]

#  yum provides */ANY_FILENAME_GOES_HERE
Make note of the rpm that results from that output and consider installing it.

# yum provides */libstdc++.so.5

4. Run the command and install the package.

5. Recheck ldd for the mysql_monitor binary if failing on the shared lib dependency

6. Activate the mysql probe or redeploy again from the local archive and it should now work.

 
 
One Exception:
RHEL8 does not provide libstdc++.so.5.  It has been attached to this KB.  Please copy this file in the path "/lib64/" in the RHEL8 machine and redeploy the mysql probe.  This libstdc++.so.5 requirement will be updated to version 6 in the probe versions after mysql 1.60.

Additional Information

Currently, only MySQL v5.x is supported not 6.

Reference:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/mysql-mysql-server-monitoring/mysql-mysql-server-monitoring-release-notes.html#concept.dita_0fa3f44e687e1bd17705ba286e5d201e4c53262c_ProbeSpecificSoftwareRequirements

Attachments

1638810030572__libstdc++.so.5 get_app