Error connecting to an agent "Unable to authenticate user for Agent"
search cancel

Error connecting to an agent "Unable to authenticate user for Agent"

book

Article ID: 188398

calendar_today

Updated On:

Products

CA Harvest Software Change Manager CA Harvest Software Change Manager - OpenMake Meister

Issue/Introduction

Harvest SCM Agent on Linux is configured to use LDAP for authentication.  When connecting to this multi-user agent via workbench, "Unable to authenticate user for Agent" error is seen

Environment

Release : All versions

Component : CA Harvest Software Change Manager

Cause

The Linux user credentials being used to connect to the agent, that user did not exist locally on the Linux server.

Resolution

The Linux user credentials being used to connect to the agent, that user should exist locally on the Linux server.  The authentication (credentials) can be validated against LDAP server, but the user itself should exist on the server.