Enabling AUTOGEN Processing in Endevor

book

Article ID: 188255

calendar_today

Updated On:

Products

Endevor Software Change Manager (SCM) Endevor Software Change Manager - Natural Integration (SCM) Endevor Software Change Manager - ECLIPSE Plugin (SCM) Endevor Software Change Manager - Enterprise Workbench (SCM)

Issue/Introduction

Attempting to utilize the AUTOGEN feature. Was recommended  to enable the following functions:

  • Enable ENHOPT AUTOGEN_SOURCE=ON             
  • Enable AUTOGEN with COPYBACK instead of NOSOURCE                                  
  • Enable ENHOPT SPAN_NONE_ALWAYS=ON     - By default (“OFF”) This option enforces SPAN=NONE for AUTOGEN

The latter parameter description versus the parameter setting seems counterintuitive.  If  uncommented the SPAN_NONE_ALWAYS=ON parameter so now it is “ON”.   Previously it was “OFF”.  With “ON” does this mean Endevor will now SPAN Systems, sub-Systems, etc.?

***********************************************************************
* THIS OPTION ENFORCES SPAN=NONE FOR AUTOGEN                           
*---------------------------------------------------------------------*
         ENHOPT SPAN_NONE_ALWAYS=ON                DEFAULT VALUE IS OFF

 

Environment

Release : 18.0 18.1 

Component : CA Endevor Software Change Manager

Resolution

SPAN_NONE_ALWAYS disallows the use of the SPAN option with AUTOGEN

  • If I default to "OFF" setting what happens with SPAN?
     Generates only those using elements that are in the same logical map of the component specified. Whether you specify "Autogen" or "Autogen Span None", the SCL is written as "Autogen Span None".
  • If I set it to "ON" setting what happens with SPAN?
     Generates using elements from all Systems and Subsystems.