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QOS processor probe is not stable

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Article ID: 188228

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

The QoS_processor probe is automatically going down and turning red
Observing the issue even after restarting it multiple times.

How can we correct this issue?

 

Environment

UIM 8.x, 9.x, 20.x
QOS_PRROCESSOR 8.x, 9.x, 20.x

Cause

The queue in the hub for the probe had been manually deleted.

Resolution

we can see the probe is shutting down after trying to connect to the hub queue.

pr 07 04:38:42:281 [Qos Monitor Loader, qos_processor] QosMessageReceiver starting.
Apr 07 04:38:42:288 [Qos Monitor Loader, qos_processor] Creating hub queue 'qos_processor_qos_message' for Qos Messages
Apr 07 04:38:42:427 [Qos Monitor Loader, qos_processor] QosProcessor Coordinator aborting: No element found for key sections
Apr 07 04:38:42:428 [Qos Monitor Loader, qos_processor] (38) , No element found for key sections


It appears that the QOS_Processor queues have been deleted from the hub configuration file.

you should have two queues such as:

<qos_processor_qos_message>
      active = yes
      type = attach
      subject = QOS_MESSAGE
   </qos_processor_qos_message>
   <qos_processor_qos_baseline>
      active = yes
      type = attach
      subject = QOS_BASELINE
   </qos_processor_qos_baseline>





Please set these queues back up and deactivate and activate the qos_processor and it should start as expected.