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Error creating ITPAM workflow

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Article ID: 188171

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

I've created an "Activity Notification" with an Event that should trigger an ITPAM workflow, however it does not trigger.  When I look at the Event History, it shows as pending.  I was able to find this message, "Error creating ITPAM workflow", in the stdlog file (which I've attached a snippet).


I failed over to the standby as background and was able to get the ITPAM workflow to work and attempted to reboot the original background, but the issue persists.  I've also confirmed that conditions and macros are working as well.

Environment

Release : 17.1

Component : SERVICE DESK MANAGER

Cause

ITPAM entries are missing in  original Background server's NX.env file , they are only presented on the standby server 

Resolution

do one of the followings to to fix it :

A .
1. fail over to that original BG server and SD service is up and running there
2. login Service Desk GUI , go to Administration -> Options Manager -> CA IT PAM Workflow , and manually install all those IT PAM related entries there ( the same as your SB server is having ) .

Note : you can login your SB's GUI first to record the value of each of those entries first and then install the same when failing over to BG server .

3. after that , you recycle BG server's SD service to have them take effect .

OR

B.

1. failover to that original BG server and SD service is up and running there

2. take a backup copy of the current NX.env on this server first

3. in DOS command line , run the following SD command :

pdm_options_mgr 

4. check NX.env file to make sure those ITPAM related entries are written into NX.env file

5. recycle service desk service to have them take effect .