Unknown agent and Key not available for node errors in tracelog of DE (dSeries)
search cancel

Unknown agent and Key not available for node errors in tracelog of DE (dSeries)

book

Article ID: 188154

calendar_today

Updated On:

Products

CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries) CA Workload Automation DE - Scheduler (dSeries)

Issue/Introduction

Manager logs show following message about "Key not available"

[ERROR] DM.InputProcessor_674: [20XX-XX-XX_00:00:26.070] Exception: Key not available for node SOME_AGENT.
com.ca.wa.publiclibrary.engine.library.crypto.CryptoException: Key not available for node SOME_AGENT.

at com.ca.wa.comp.library.communications.WAKeyObtainerImpl.getKey(WAKeyObtainerImpl.java:63).....

Environment

Release : 12.x

Component : CA WORKLOAD AUTOMATION DE, WA Agent 

 

 

Cause

These are WA Agents that have been installed but were not added to the CA Workload Automation Manager (e.g. DE).  Or they were once part of managers, and were likely removed from manager side but agents were not shutdown or uninstalled.

Resolution

If unknown agents constantly keep contacting then manager/scheduler has to spend resources to check the agent messages and discard them. These messages from WA Agent can cause performance issues in the long run.  The following may be done:
 
1.  If the agent(s) are no longer needed and no jobs are scheduled for them, then connect to agent machine and shutdown the agent.
2.  If the agent(s) are not recognizable then enable extra logging in manager to get the IP address.  Then connect to agent machine and stop the agent.
 
For DE:
Go to Topology -> Configure Logging 
 

 

Change these three settings from WARN or INFO to ALL

agent:afm (default WARN)

communications (default INFO)

dm:communications (default INFO)

 

The changes take effect immediately. Collect the logs for about an hour, then revert back to your previous or default logging.  Get the IP addresses from tracelog and then connect to the host and shut them down if desired.

 

If all WA Agent user standard keys and ports, then  add the Agents back to the Topology and then shut them down.  This will stop them from constantly pinging the DE manager.

Note: Don't forget to remove them from theTopology after shutting the agents down.