"AHD4409 pdmweb is unable to connect with the web engine" after restarting CA Service Desk
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"AHD4409 pdmweb is unable to connect with the web engine" after restarting CA Service Desk

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Article ID: 18812

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

After restarting CA Service Desk, the Secondary server Tomcat engines stop responding and would give a message like: "AHD4409 pdmweb is unable to connect with the web engine".

Environment

Release:  Service Desk 12.7 and later
Component: CA Service Desk Manager

Cause

Normally this problem happens if the server (domsrvr) is not fully initialized before tomcat starts.

Resolution

Change NX.env and NX.env template file (NX_ROOT\pdmconf\nx.env_nt.tpl) of all SDM servers:

From:

! NX_SLUMP_FIXED_SOCKETS=1
! NX_SLUMP_SECONDARY_SOCKET=2100

TO (trade the "!" comment for "@"):

@NX_SLUMP_FIXED_SOCKETS=1
@NX_SLUMP_SECONDARY_SOCKET=2100

Note: You could also use pdm_options_mgr command line to install the above options as well. Refer to Reference Guide for more information on how to use the same.

During the startup of a Primary, the Primary server could becomes really busy starting a lot of needed components. So the machine (not slump, but Windows) may not be able to respond quickly to incoming TCP requests etc. That's why the Secondary Tomcat server encounters issue where it can't get a connection successfully established in time. So we can sset a time delay so that the tomcat will try to connect to slump a little after Primary settles down.

There are 2 ways to accomplish this:

  1. A short term fix would be to take these steps on the secondary/app server:

    pdm_tomcat_nxd -c stop
    pdm_tomcat_nxd -c status
    (to make sure it shows as "Stopped"
    Wait 30 - 60 seconds and then issue this command:
    pdm_tomcat_nxd -c start
  2. A long term solution would be to update these 2 files (same section) on the primary/background server:

    <Service Desk>\pdmconf\pdm_startup
    <Service Desk>\pdmconf\pdm_startup.tpl

    Change the section related to TOMCAT located in the secondary/app servers.
    In below examples [SECONDARY SERVER 1] and [SECONDARY SERVER 2] are secondary servers.
    +120 means that we are delaying 120 seconds (2 minutes) to startup TOMCAT on secondary servers.
    You can adjust this value according to your needs.

    PDM_TOMCAT_CONTROLLER (_pdm_tomcat_[SECONDARY SERVER 1],"[SECONDARY SERVER 1]", pdm_tomcat-[SECONDARY SERVER 1])
    after domsrvr connects + 120
    after _ver_ctl_[SECONDARY SERVER 1] finishes
    after _msgcat_build_[SECONDARY SERVER 1] finishes

    PDM_TOMCAT_CONTROLLER (_pdm_tomcat_[SECONDARY SERVER 2],"[SECONDARY SERVER 2]", pdm_tomcat-[SECONDARY SERVER 2])
    after domsrvr connects + 120
    after _ver_ctl_[SECONDARY SERVER 2] finishes
    after _msgcat_build_[SECONDARY SERVER 2] finishes

Restart the Service Desk Services in below order:

  1. Stop on Primary
  2. Stop on Secondary servers
  3. Start on Secondary servers
  4. Start on Primary

Additional Information

Additionally, check that the Tomcat entries are present and running by running pdm_status.

Check the NX.env file noticed that the Java path was set to 11.0.12 but that java version was located inside of that folder. 

Copied the Java folder to match what was inside of NX.env file.  

In some cases, adding variable NX_SKIP_USP_PREFERENCES_AT_STARTUP to the NX.env file may help