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UMP - Mixed metrics after changing robot IP address

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Article ID: 188070

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Three robots changed its IP addresses, and only one is showing all cdm probe metrics, for file system and CPU/RAM usage.
When reviewing the metrics displayed in USM for this robot (Details and Metrics tab), it seems these are not its metrics, but the metrics of one of the other robots.

Cause

After changing the robot ip addresses, without following the proper steps when this occurs, seems to have mixed the metrics sources, to different devices/computers
Using next query we determined that not all metrics in S_QOS_DATA table, from the same source, were linked to the same device (CM_CONFIGURATION_ITEM) or computer (CM_COMPUTER_SYSTEM)

SELECT cm_configuration_item_metric.ci_metric_id, dev_ip, dev_name, cm_computer_system.cs_id, name, ip, origin
FROM cm_configuration_item_metric 
INNER JOIN cm_configuration_item ON cm_configuration_item_metric.ci_id = cm_configuration_item.ci_id
INNER JOIN cm_device ON cm_configuration_item.dev_id = cm_device.dev_id
INNER JOIN cm_computer_system ON cm_device.cs_id = cm_computer_system.cs_id
WHERE ci_metric_id IN
(SELECT ci_metric_id FROM s_qos_data WHERE probe = 'cdm' AND source = 'XXXXXXXX')

Replacing XXXXXXXX, by the robot name (in next example: robot02) it should return something like next, where cs_id is the same on all rows:



That means the metrics in S_QOS_DATA for this robot are associated to one device/computer in CM_CONFIGURATION_ITEM and CM_COMPUTER_SYSTEM
If the query return different cs_id, it means the metrics are mixed. Metrics collected from one robot, will appear in a different robot in USM


Environment

Release : 8.5

Component : UIMUPS

Resolution

After following next steps the problem should be resolved. However it could take, even hours, before all the metrics to start to be displayed in USM

1. Stop the robot watcher service
2. Clear the <NImsoft>/niscache folder on ALL robots that had have the problem 
3. Remove ALL robots, that have the problem, from USM. Do not check any of the options when doing the delete
4. Go into S_QOS_DATA and null out the ci_metric_id
    UPDATE S_QOS_DATA SET CI_METRIC_ID = NULL WHERE source IN (robot01, robot2, robot3, ..., robotn) 
    Inside the parentheses, put the robots name affected by the issue
5. Start the robot service
6. Restart the discovery_server and data_engine probes.

Additional Information

Articles related

How to link tables to display QOS data and alarms
https://knowledge.broadcom.com/external/article?articleId=34712

No Metrics Available after machine upgrade where hostname is the same but IP was changed
https://knowledge.broadcom.com/external/article?articleId=57027

Recommended procedure for robot rename or change of IP
https://knowledge.broadcom.com/external/article?articleId=137766

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