ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

NX.ENV and config.properties after update Tomcat for CA SDM, cawf tomcat references

book

Article ID: 188033

calendar_today

Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

We recently updated Tomcat (8.5.53) for CA SDM (17.1.03), during the update we fixed the Tomcat version in NX.ENV and config.properties:


-NX.ENV

@NX_TOMCAT_INSTALL_DIR=E:/CA/SC/tomcat/8.5.53

@NX_TOMCAT_INSTALL_DIR_CAWF=E:/CA/SC/tomcat/8.5.53

-config.properties

web.tomcat_home=E\:\\CA\\SC\\tomcat\\8.5.53

web.cawf_tomcat_home=E\:\\CA\\SC\\tomcat\\8.5.53

web.tomcat.version=8.5.53

Subsequently, we apply the rollup 17.1.0.8 and observe that the variables NX_TOMCAT_INSTALL_DIR_CAWF and web.cawf_tomcat_home have the value "8.5.6" again.

The same thing happens after running the pdm_configure command.

Do you have information about it? Are these variables used in current versions of CA SDM?

 

Cause

cawf tomcat variable references not updated correctly.

Environment

Release : 17.1

Component : SERVICE DESK MANAGER

Resolution

The CAWF variables are related to the integration with our past CA  product named CA Workflow.
You can check in your ServiceDesk environment if the CA Workflow integration is setup by going to:

         Administration-Option Manager- CA Workflow.

You will see here a list of other cawf variables.
If you do not have these cawf variables installed, you can disregard the cawf variables named  in the issue decription and which make reference to the specific tomcat instance for the CA Workflow integration