Best Practice for Adding New Landscapes in Spectrum
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Best Practice for Adding New Landscapes in Spectrum

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Article ID: 188029

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Updated On:

Products

CA Spectrum

Issue/Introduction

We have recently added 2 new landscape servers to our existing Spectrum environment.

We are able to see those landscapes present under the default events in event configuration. When we checked the custom events (0xfff....), we cannot see those newly added landscapes. We want to know if there are any steps needed(like copying custom folder from existing landscape to the new one) after adding the landscape to the existing MLS.

In the new landscape server, we are not able to see any files under Events folder.  Not able to see newly created landscapes in Event configuration of custom events

 

Environment

Component : Spectrum Core / SpectroSERVER

Cause

The catalog and custom events need to be populated to the new SpectroSERVER.

Resolution

 When setting up new landscapes:

 

  1. Import the catalog from the MLS – if you don’t do that then your attribute sync will be off.  To do it:  Take the latest SSdb save from the MLS, move it to the new SS.  On the new SS, stop the SS process and load JUST THE CATALOG portion from the SSdb file. From command line, in the $SPECROOT/SS directory, run:  ../SS-Tools/SSdbload -c ../SS-DB-Backup/SSdb_savefile_from_the_MLS

Start the SS back up.  This only loads the catalog portion and does not overwrite the models.

  1. Copy the entire $SPECROOT/custom folder from the MLS to the new landscape.
  2. If AlarmNotifier is running on individual landscapes, copy the $SPECROOT/Notifier folder too – This may not be needed so do on an as needed basis.

Additional Information

You may also need to populate the users depending upon which version of Spectrum (NetOps) you are running.  You may need to navigate to the Users tab and click on each group and add the new landscape to the user group.