"Can't set default user - can't find information for session 0" messages in the stdlogs
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Article ID: 18794
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Updated On:
Products
CA Service Management - Service Desk Manager
Issue/Introduction
The error message, "Can't set default user - can't find information for session 0", is written to the stdlog by the domsrvr during the shutdown and during the startup of CA Service Desk Manager services whenever the "default_superuser_id" option is not installed (see Figure 1). The message is also written to the stdlog after clicking the "Install" button to install the option.
An example of the stdlog entry is:
03/27 06:33:34.81 [EXAMPLE SDM-SERVER] domsrvr 26632 ERROR dob.c 1477 Can't set default user - can't find information for session 0
Environment
Release: all Component: Service Desk Manager
Cause
The default_superuser_id option is Not Installed.
Resolution
To solve the error, follow these steps:
Log in to the CA Service Desk Manager GUI, and, using a role that has access to the Administration tab, such as the Administrator role, click on the Administration tab.
Open the Options Manager folder by clicking on it, locate the General subfolder and click on it. The Option List should now be displayed in the right side pane.
In the Option List, look down the Option column and find the row for "default_superuser_id", click on the option name.
In the "default_superuser_id Options Detail" form, click the Edit button, confirm that a valid Option Value is set (such as ServiceDesk) and then click the Install button (see Figure 2).
Recycle CA Service Desk Manager services.
Figure 1. Install the default_superuser_id option.