CDA: How to rebuild CDA Search Index
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CDA: How to rebuild CDA Search Index

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Article ID: 187917

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

How to utilize admin-cli.exe to ClearAllIndex? 

There is a documentation page about utilizing the admin-cli.exe: https://docs.automic.com/documentation/webhelp/english/ARA/12.3/DOCU/12.3/CDA%20Guides/Default.htm#CDA/CLI/cli_ClearAllIndex.htm%3FTocPath%3DReference%7CCLI%2520%2520Commands%2520for%2520CDA%2520Server%7C_____3

Potential issues: When you type the command similar to the one listed in the documentation, you either get no results or the following error: 'Error: 1, Invalid command or invalid options.' The question is, what is the right command to execute admin-cli.exe to ClearAllIndex? 

Environment

Release : 12.1, 12.2, 12.3

Component : AUTOMATION ENGINE. CDA

Cause

Admin error: The server specification is incorrect.

Potential issues: either get no results or the following error: 'Error: 1, Invalid command or invalid options.' 

Resolution

Here is the example of command you need to execute:

C:\Automic\Release.Manager\Utilities\AdminCLI>admin-cli.exe

Host URI: myserver:80/CDA
User: AUTOMIC/100/MARIA/SUPPORT
Password: ****
Success
AUTOMIC/100/MARIA/SUPPORT> clearallindex
Success:

Specifications: 

1. Use the following once you start your admin-cli.exe:

yourserver:80/CDA (it is important to use 80 port and the CDA name). It may not be CDA, depending on the install, it could have possibly been changed. To make sure you use the right link, just copy UC4Deployment.CallbackUrl from your customer.config file - located in Automic\Release.Manager\WebUI\).

2. User should be specified as SYSTEMNAME/CLIENT#/USERNAME/DEPARTMENT