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Information Centric Tagging - UNIQUE KEY constraint violation.

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Article ID: 187915

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Updated On:

Products

Information Centric Tagging

Issue/Introduction

Symantec Information Centric Tagging (ICT)

Unable to grant roles or licenses to a user, or otherwise modify that user.

Error:
cs_server_common.BO.CannotAccessDatabaseException: Error while accessing Information Centric Tagging administration database. ---> System.Data.SqlClient.SqlException: Violation of UNIQUE KEY constraint 'UQ_Users_user_principal_name'. Cannot insert duplicate key in object 'dbo.Users'. The duplicate key value is ([email protected]).

Cause

That user was previously a contractor and was then hired on as an employee.
That user had a different user ID when a contractor than the one she has now as an employee.
But, the user's email address is the same now as it was when she was a contractor.

The user shows up in the ICT console as her new employee user ID.
But the ICT license for her email is associated with her old contractor user ID.
In ICT, the user's email cannot be associated with more than one user ID (user principal name).

Resolution

Ensure the old contractor user ID is not in the ICT console.
Then, on the Licenses tab, click the "Purge Unused Licenses" button and accept the prompt.
This will purge the old contractor user ID from the dbo.Users table.
After which, you are able to add and modify the new employee user ID associated with that email address.