Can't access a website using a WebUPortal: "Network mount for session recording unavailable"
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Can't access a website using a WebUPortal: "Network mount for session recording unavailable"

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Article ID: 187898

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Updated On:

Products

CA Privileged Access Manager (PAM) CA Privileged Access Manager - Cloakware Password Authority (PA) CA Privileged Access Manager - Server Control (PAMSC)

Issue/Introduction

I'm trying to access a Web Portal, but I receive the following error:  "Network mount for session recording unavailable"  (see screenshot below)

The Mount settings are OK, and SSH and RDP connections work fine, but web applications do not..

The cluster was turned off, nodes were rebooted the nodes, mount was unmounted and remounted and Available, and then cluster restarted.

 

Environment

Release : 3.2.x, 3.3.x, 3.4.X

Component : PRIVILEGED ACCESS MANAGEMENT

Cause

With recording turned on, the webui would timeout with the noted error. 
Tested turning off recording and the webui worked.
The problem seemed to be centered around the webui with recording on.

Resolution

The webui uses 'wget' while it attempts to connect.  Wget (originally know as Geturl) does dns translation as the webui tries to connect, and it may be failing to reach one of the DNS servers.
The DNS servers are listed in Configuration/Network/Network Settings/ page, and there were 3 DNS servers listed.
To test the DNS servers, you can go to the Configuration/Tools page and use Reverse Lookup to check an IP or a DNS name on each server.
On testing the 3rd server, it could not complete the nslookup.  
The 3rd server was removed from resolver.conf, and customer was immediately able to connect with the webui interface.