search cancel

Tomcat unresponsive and web services operations fail

book

Article ID: 187876

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

Restarting the Secondary server services may make the secondary Tomcat unresponsive and web services operations may fail with invalid SID

Cause

The following error may be seen in the secondary servers jsrvr.log file.

                 08/08 10:49:04.186[TCP_port-Write:Slump_nxd]
                 ERROR TCP_port 1390 cannot write to
                 XXXXXXjava.net.SocketException: Socket closed at
                 java.net.SocketOutputStream.socketWrite(Unknown
                 Source)
                 at java.net.SocketOutputStream.write(Unknown
                 Source)
                 at java.io.DataOutputStream.writeInt(Unknown
                 Source)
                 at
                 com.ca.ServicePlus.slump.TCP_port.send(TCP_port.ja
                 va:1380)
                 at
                 com.ca.ServicePlus.slump.TCP_port.send(TCP_port.ja
                 va:1324)
                 at
                 com.ca.ServicePlus.slump.TCP_port$write_Thread.run
                 (TCP_port.java:1832)
                 
                 The following error may be seen in the secondary
                 servers pdm_tomcat.log file.
                 java.io.IOException: Slump logon failed for
                 process pdmweb:XXXXXX#6f181a8f:16c706ad0aa:-7fff
                 at
                 com.ca.ServicePlus.slump.SLUMP.doSlumpLogon(SLUMP.
                 java:556)
                 at
                 com.ca.ServicePlus.slump.SLUMP.logon(SLUMP.java:47
                 5)
                 at
                 com.ca.ServicePlus.pdmweb.SLUMPTC.initSlump(SLUMPT
                 C.java:382)
                 at
                 com.ca.ServicePlus.pdmweb.SLUMPTC.run(SLUMPTC.java
                 :944)

Environment

Release : 17.1

Component : SERVICE DESK MANAGER

Resolution

Please contact support for an available fix.
 
Once you have encountered the issue the current resolution is to install:
 
1. T56H119.CAZ on top of 17.1 + RU08
 
This fix will be included in future roll-ups.