Autosys client (utilities) not connecting/working
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Autosys client (utilities) not connecting/working

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Article ID: 187763

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Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - System Agent (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) Workload Automation Agent Autosys Workload Automation

Issue/Introduction

I have installed Agent and Client. Agent can run jobs without any problem but the Client does not connect.
 
autorep -J job%
CAUAJM_E_10029 Communication attempt with the CA WAAE Application Server has failed! [appserver*****:9000]
CAUAJM_E_10029 Communication attempt with the CA WAAE Application Server has failed! [appserver*****:9000]
CAUAJM_E_10221 Exhausted list of available Application Server(s). Failing request.
CAUAJM_E_50033 Error initializing tx subsystem:  CAUAJM_E_10062 Failed to get initial configuration from CA WAAE Application Server(s)

Environment

Release : 11.3.6

Component : CA Workload Automation AE (AutoSys)

O.S: Linux/Unix

Cause

The problem can occur due to configuration issues in Client configuration files

It can also be due to Firewall Blockage with Ports

Csam Settings Port Multiplexing Mismatch
Security/Encryption Settings (UseEncryption Settings) Mismatch
Host Communication (Tcp/Ip) Failures

Resolution

Client configuration issues

 
There should be a config file on the client machine in $AUTOUSER folder.

We need to confirm that the entry AUTOSERVER is correctly pointed to host running the application server

Verify if the application server is running on the host
 

#cd /etc/init.d

#./waae_server.PRD status

#WAAE Application Server (PRD)               -  not active


We also need to verify the  AutoServerPort is mentioned in the config file corresponds to the correct port of the application server.

In Windows servers, you can go to administrator utility on the client machine
Click on the AutoSys tab and select the application server and update the "server host".

Then restart SSA as follows

In windows restart the service "CA connection Broker" on windows.

On a Linux machine, you restart as follows
cd $CSAM_SOCKADAPTER/bin
./csampmux stop
./csampmux start

Connectivity issue due to Firewall
 
To avoid all of the issues please follow below points:
 
Make sure the below ports are open and bi-directional ( Firewall should be disabled on these ports)
 
7163, 7520, 7507, 7500
 
Check EnablePmux values set to True on both Client Machine and Server Machine
 
$CSAM_SOCKADAPTER/bin/ ./csamconfigedit port=9000 display
 
- Security/Encryption Settings (UseEncryption Settings) Mismatch
 
$AUTOUSER/config.<INS> -> Check for 'UseEncryption' settings on both Client and Server machine Should be Same.