Unable to capture performance metrics for Bluecoat SG devices
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Unable to capture performance metrics for Bluecoat SG devices

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Article ID: 187630

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Updated On:

Products

CA Spectrum CA eHealth

Issue/Introduction

We are unable to capture Performance data for BlueCoat devices for Spectrum.  We are seeing empty graphs on the Performance Tab.

We are seeing this issue on at least these devices, possibly more. Some are Certified within Spectrum already. 

1.3.6.1.4.1.3417.1.1.27
1.3.6.1.4.1.3417.1.1.34
1.3.6.1.4.1.3417.1.1.38
 

 

Environment

Release : 10.3

Release : 10.4.X

Component : Spectrum Core / SpectroSERVER

Cause

There is a vendor issue preventing Spectrum from polling CPU or Memory metrics from BlueCoat devices.

Resolution

There is a vendor issue preventing Spectrum from polling CPU or Mem metrics from BlueCoat devices. The reason is as follows: 


1. Spectrum populates the performance tab with data gathered from NRM based attributes. In some cases, a vendor may provide metrics in unique attributes. In those cases, attribute redirection can be used to point Spectrum to the proper attrs on the device. The vendor is responsible for providing details in their MIBs.  More Details on this Here

2. BlueCoat provides documentation on their available CPU and Memory tracking, "Blue_Coat_SNMP_Critical_Resource_Monitoring", which is also attached to this KB for reference. BlueCoat identifies some performance metrics within BLUECOAT-SG-PROXY-MIB. For example the CPU related attrs as follows: 
 
NOTE: BLUECOAT-MIB, BLUECOAT-SG-PROXY-MIB, and BLUECOAT-SG-USAGE-MIB are not provided in Spectrum by default (at time of version 10.4.1 release). It is recommended to download and import these MIBs to MIB Tools to view these attributes within Spectrum. 

3. As you can see there are no attrs here for "usage" or "utilization" meaning BlueCoat does not have any attrs which are storing calculated CPU usage. Even such attr as "sgProxyCpuBusyPerCent" is depreciated, and has a Description to use other table attrs, which Spectrum would not be able to read. 





4. It is clear that Bluecoat is not providing the required information for Spectrum to properly poll and display CPU and Mem data on Performance tab. This is a vendor issue and we recommend to reach BlueCoat for further information.  


Additional Information

 

Attachments

1585662123193__Blue_Coat_SNMP_Critical_Resource_Monitoring.8.pdf get_app