Cookie Settings
Memory Utilization report is not correct
search
cancel
Search
Memory Utilization report is not correct
book
Article ID: 187580
calendar_today
Updated On:
02-02-2024
Products
CA Performance Management
Network Observability
Show More
Show Less
Issue/Introduction
For some Routers the PM report show an incorrect memory utilization like this:
On Spectrum:
PM Report by components:
Environment
Performance Management Release : 3.7
Cause
The memory reserved and image are typical of the device operating system very similar to / proc on unix; they will always be 100%.
Resolution
DC Debug show:
Item ID=543846, Name=MemoryPool processor 1
Item ID=543847, Name=MemoryPool reserved 6
Item ID=543848, Name=MemoryPool image 7
Vertica query:
drdata=> select to_timestamp(tstamp), item_id, im_utilization from dauser.physical_memstats_rate where item_id in (543846,543847,543848) and tstamp >= 1585044000 and tstamp <= 1585044900 order by 1,2;
to_timestamp | item_id | im_utilization
---------------------+---------+------------------
2020-03-24 07:00:00 | 543846 | 37.4785061258428
2020-03-24 07:00:00 | 543847 | 100
2020-03-24 07:00:00 | 543848 | 100
2020-03-24 07:05:00 | 543846 | 37.4785061258428
2020-03-24 07:05:00 | 543847 | 100
2020-03-24 07:05:00 | 543848 | 100
2020-03-24 07:10:00 | 543846 | 37.4785061258428
2020-03-24 07:10:00 | 543847 | 100
2020-03-24 07:10:00 | 543848 | 100
2020-03-24 07:15:00 | 543846 | 37.4785061258428
2020-03-24 07:15:00 | 543847 | 100
2020-03-24 07:15:00 | 543848 | 100
(12 rows)
The average from Vertica query is 79% like the NetOps Portal report because the gauges are all Memory components being aggregated together across the entire time range so the report is correct
Additional Information
Article Id: 33163 - How to collect logging for interface data issues in Performance Management
https://ca-broadcom.wolkenservicedesk.com/external/article?articleId=33163
Feedback
thumb_up
Yes
thumb_down
No