ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

MFA- Do we have separate fixes for them too? If so can you please provide the links for them.

book

Article ID: 187429

calendar_today

Updated On:

Products

CA Advanced Authentication - Strong Authentication (AuthMinder / WebFort) CA Strong Authentication CA Rapid App Security CA Risk Authentication CA Advanced Authentication

Issue/Introduction

Looks like the below Vulnerability is more related to Apache tomcat and not specific to any CA products. We not only have access Gateway using Tomcat, we also have MFA and Identity Portal(14.2 currently active in prod) using Tomcat servers. From what I understood about ghostcat vulnerabilities it should impact all the products that use Tomcat. Do we have separate fixes for them too? If so can you please provide the links for them.
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

This notice is to alert you to the availability of patches and instructions regarding the Ghostcat vulnerability (https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-1938 and https://nvd.nist.gov/vuln/detail/CVE-2020-1938).   This vulnerability is rated at 9.8 Critical Severity.  Please give this high attention.

SiteMinder embeds Apache Tomcat in the SiteMinder Access Gateway and the SiteMinder Agent for SharePoint and makes use of the Apache JServ Protocol (AJP).   Patches and deployment instructions for the following versions of these SiteMinder components are being made available via this location

https://techdocs.broadcom.com/us/product-content/recommended-reading/technical-document-index/ca-single-sign-on-hotfix-cumulative-release-index.html#SMWAM

When you reach that location, search on “Ghost” and you will find a link to deployment instructions and to the patches for each of these:

  ·       Access Gateway (previously SPS) versions 12.8.x, 12.7.x, 12.6.x ·       Agent for SharePoint version 12.52 SP1 (all CRs)  

The method to exploit this vulnerability is not described in the CVE detail.  However, in order to provide a higher level of assurance to our customers we are providing these patches.

Cause

When using the Apache JServ Protocol (AJP), care must be taken when trusting incoming connections to Apache Tomcat. Tomcat treats AJP connections as having higher trust than, for example, a similar HTTP connection. If such connections are available to an attacker, they can be exploited in ways that may be surprising. In Apache Tomcat 9.0.0.M1 to 9.0.0.30, 8.5.0 to 8.5.50 and 7.0.0 to 7.0.99, Tomcat shipped with an AJP Connector enabled by default that listened on all configured IP addresses. It was expected (and recommended in the security guide) that this Connector would be disabled if not required. This vulnerability report identified a mechanism that allowed: - returning arbitrary files from anywhere in the web application - processing any file in the web application as a JSP Further, if the web application allowed file upload and stored those files within the web application (or the attacker was able to control the content of the web application by some other means) then this, along with the ability to process a file as a JSP, made remote code execution possible.

Environment

Release : 9.1

Component : AuthMinder(Arcot WebFort), RiskMinder

Resolution

Advanced authentication do not ship Tomcat application server and to address the issue customers have to upgrade Tomcat to a version where this vulnerability is addressed.
It is important to note that mitigation is only required if an AJP port is accessible to untrusted users. Users wishing to take a defence-in-depth approach and block the vector that permits returning arbitrary files and execution as JSP may upgrade to Apache Tomcat 9.0.31, 8.5.51 or 7.0.100 or later. A number of changes were made to the default AJP Connector configuration in 9.0.31 to harden the default configuration. It is likely that users upgrading to 9.0.31, 8.5.51 or 7.0.100 or later will need to make small changes to their configurations.