Client fails to register with SEPM server due to issues with IP Address information
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Client fails to register with SEPM server due to issues with IP Address information

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Article ID: 187415

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Updated On:

Products

Endpoint Protection

Issue/Introduction

After upgrading the Endpoint Protection software on a client machine to SEP 14.2 or higher the machine no longer successfully registers with the Endpoint Protection Manager.

When reviewing the SEPM server's log for an explanation the following error is found in the scm-server-0.log file.

com.microsoft.sqlserver.jdbc.SQLServerException: Arithmetic overflow error for data type tinyint, value = 256.

Environment

Release : Endpoint Protection 14.2 or newer

Component : 

Cause

As part of the SEP client registration process the client provided the SEPM with all the client's IP Addresses assigned to the machine. The IP address information for each client is stored in the SEM_COMPUTER_NIC table of the SEM5 database. This table contains an entry for each IP address and the field NIC_NUMBER contains the number of the IP address for the specific nic. This field is defined as a tinyint limiting its value to 256.

Endpoint Protection 14.2 introduced the new communication module for SEP to SEPM communication. This module replaces the old sylink method that was used prior to this release.  This new module submits all IP Address information from the client. Previously the sylink method only submitted the first 4 IP addresses.

Resolution

At this time there are no plans to modify the SEP client's behavior on reporting the IP address information to the SEPM or updating the database schema to allow for more than 256 entries per NIC.

Workaround:
- Reduce the number of IP addresses associated with a SEP client
- Modify the NIC_NUMBER column in the table SEM_COMPUTER_NIC from tinyint to int to allow for more than 256 IP addresses.