Resolving DB01801E - INTERFACE ERROR - 44 and DB00502E RETURN CODE 83 (080) errors
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Resolving DB01801E - INTERFACE ERROR - 44 and DB00502E RETURN CODE 83 (080) errors

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Article ID: 18735

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Updated On:

Products

Datacom Datacom/AD Datacom/DB

Issue/Introduction

I just upgraded my Datacom software, and when I tested my application on the same LPAR as the Multi-User Facility (called MUF), it worked fine. However, when I ran the same test from a different LPAR, I received errors:

DB01801E - INTERFACE ERROR - 44
DB00502E - REQUEST ERROR - RETURN CODE 83 (080)

Environment

Release: all

Component : Datacom/AD

Component : Datacom/DB

Cause

These errors indicate that on the remote system, you have not run CAS9 or the CAIRIM program to define the PC Call modules.

Resolution

These error messages:

DB01801E - INTERFACE ERROR - 44
DB00502E - REQUEST ERROR - RETURN CODE 83 (080)

are indicative of a problem with your environment. The Interface Error 44 indicates that on the remote system, you have not run CAS9 or the CAIRIM program to define the PC Call modules. This is found in the installation job AXRIM01 for Datacom/AD and BDRIM01 for Datacom/DB. The DBUTLTY function REPORT MEMORY=MVS provides a listing of the installed and available PC routines on each LPAR where the job is run.

Additional Information

As always, please contact Broadcom support for Datacom if you have further questions.