ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Upgrade path

book

Article ID: 187310

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Hello,

We would like to upgrade our non-prod UIM infra to DX Infrastructure Management 20.1.

I've check the upgrade path from this page: https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/20-1/installing/product-compatibility/supported-upgrade-paths.html

We see:

  • UMP 9.2.0 to UMP 20.1
  • UMP 9.1.0 to UMP 9.2.0
  • UMP 9.0.2 to UMP 9.2.0

We've check the page: http://xxxxxxxump001/html/version.txt and this is what we see:

Version      = 9.0.3
Build Label  = UMP_903_GA
Build Date   = Wed Dec 26 15:23:15 2018 +0000
Build Number = 0

Does that means that I need to upgrade UMP to version 9.20 first and then I can proceed with the upgrade to 20.1?

Environment

Release : 9.0.2

Component : UIM

Resolution

In your case with UIM/UMP 9.02/9.03, please upgrade to 9.20 first.

1. Upgrade UIM 9.0.2 to UIM 9.2.0
2. Upgrade UMP 9.02/9.03 to 9.2.0
3. Then do the same for 9.20, upgrade UIM, then UMP to 20.1. See upgrade paths below.

Here are the supported upgrade paths
https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/9-0-2/installing/product-compatibility/supported-upgrade-paths.html

UIM Compatibility Matrix
https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/9-0-2/installing/product-compatibility/ca-uim-compatibility-matrix.html

CA Unified Infrastructure Management 9.2.0 Release Notes
https://techdocs.broadcom.com/content/broadcom/techdocs/us/en/ca-enterprise-software/it-operations-management/unified-infrastructure-management/9-0-2/release-notes/ca-uim-9-service-pack-1.html

The installer uses a package called uimserverpackages.zip.

Warning: If the install files are always downloaded to the same location, then uimserverpackages.zip is renamed to uimserverpackages(1).zip and the installer uses the pre-existing uimserverpackages.zip which is 9.0.2. The install works but UIM doesn't. So make sure you download the uimserverpackages.zip file for UIM v9.20 and don't make that mistake.