OWB Error: Unable to find the definition file
search cancel

OWB Error: Unable to find the definition file

book

Article ID: 187274

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When trying to select a custom view in Open Workbench (OWB), receive below error:

Unable to find the definition file.
C\Users\UserID\Documents\Custom Views\viewname.rwv

Environment

Release : All Supported releases

Component : Clarity PPM SAAS OPEN WORKBENCH (OWB)

Cause

  • This can be due to user not have access to view/folder related to the view.
  • It can happen if there's also been a recent change including moving data to Microsoft OneDrive

Resolution

  1. Move the view the file to the C:\Program Files\Open Workbench\views\ folder, then change the Corporate View Library point to: C:\Program Files\Open Workkbench\views\Standard_en.rwl.
  2. Make sure users have access rights to the folder where the views are located.
  3. OneDrive can cause issues (see the below), so if the files are located there, see if moving the files to a location the user has access to outside One Drive helps. 
    •  OneDrive by default does not sync anything in C:, such as:\C:\Program Files (x86) which is where C:\Program Files (x86)\Open Workbench would be.