CA DB2 Tools APPLY of maintenance leaves multiple ptfs applied in error
book
Article ID: 187221
calendar_today
Updated On:
Products
RC Compare for DB2 for z/OSDatabase Management for DB2 for z/OS - Administration SuiteEndevor Interface for DB2 for z/OSEndevor Interface for Remote Db2 for z/OSRC/Extract for DB2 for z/OSRC/Migrator for DB2 for z/OSRC/Merger for DB2 for z/OSRC/Query for DB2 for z/OSRC/Secure for DB2 for z/OSRC/Update for DB2 for z/OS
Issue/Introduction
Applying new maintenance to the r20 base install that had previously applied maintenance results in 55 PTF's showing "Applied in Error".
Environment
Release : 20.0
Component : DB2 Common Components
Cause
The cause of the ptfs in error was due to the ZFS file system not being mounted or incorrectly mounted. The following message on the apply was the cause: /products/CADB2/PDTAAMKD: /products/CADB2/PDTAAMKD: not found
Resolution
Correctly mounting the CDBAZFS file system and ensuring the CINSHFS and CSQ2HFS DDDEFs pointed to the correct USS directory allowed for the subsequent apply to succeed.