After the install of Service Desk Manager Roll-up patches, the post-intstall pdm_configure fails at the "Create Localized Resource" step
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After the install of Service Desk Manager Roll-up patches, the post-intstall pdm_configure fails at the "Create Localized Resource" step

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Article ID: 187145

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

The installation of the Service Desk Manager (SDM) Roll-up patch (RU) fails at the post-install pdm_configure "Create localized resources" task

An error similar to the following is seen within the NX_ROOT\LOG\RESOURCE.LOG file

PDM_I18N tag "Notify_Msg_Tpl:notify_msg_body_html:1163:Host_nbsp;Name" is used in C:\CA\SERVIC~1\data\tagged\cm.dat , but not defined in C:\CA\SERVIC~1\data\xml\cm.xml

Environment

Service Desk Manager 17.x

All Supported Windows Operating Systems

Cause

Incorrect XML file in NX_ROOT\data\xml directory

Resolution

In the example above, the offending file is the NX_ROOT\data\xml\cm.xml file.
 
1.  Backup the current cm.xml file located in the NX_ROOT\data\xml directory 
 
2.  Contact Broadcom Support to get a new corrected cm.xml file or correct it by adding the missing sections (see below)
 
Steps to correct the cm.xml file causing the pdm_configure issue:
 
1. Edit the incorrect NX_ROOT\data\xml cm.xml file with a text editor
 
2. Locate

<ResourceString>
        <tag>Spell_Macro:sym:300105:INTERNAL CRALG PROP_CHANGED</tag>
        <value>INTERNAL CRALG PROP_CHANGED</value>
</ResourceString>
 
3. Add
 
   <ResourceString>
        <tag>Spell_Macro:description:300106:Activity Property Changed notification</tag>
        <value>Ownership Change Activity Notification</value>
    </ResourceString>
    <ResourceString>
        <tag>Spell_Macro:sym:300106:INTERNAL ISSALG PROP_CHANGED</tag>
        <value>INTERNAL ISSALG PROP_CHANGED</value>
    </ResourceString>
    <ResourceString>
        <tag>Spell_Macro:description:300107:Activity Property Changed notification</tag>
        <value>Ownership Change Activity Notification</value>
    </ResourceString>
    <ResourceString>
        <tag>Spell_Macro:sym:300107:INTERNAL CHGALG PROP_CHANGED</tag>
        <value>INTERNAL CHGALG PROP_CHANGED</value>
    </ResourceString>
    <ResourceString>
        <tag>Spell_Macro:description:300108:Activity Property Changed notification</tag>
        <value>Ownership Change Activity Notification</value>
    </ResourceString>
    <ResourceString>
        <tag>Spell_Macro:sym:300108:INTERNAL MGSALG PROP_CHANGED</tag>
        <value>INTERNAL MGSALG PROP_CHANGED</value>
    </ResourceString>
 
4. Locate

<ResourceString>
        <tag>Spell_Macro:sym:5900:INTERNAL CRALG HEAT_CHANGED</tag>
        <value>INTERNAL CRALG HEAT_CHANGED</value>
</ResourceString>
 
5. Add
 
    <ResourceString>
        <tag>Spell_Macro:description:5901:Activity Heat Changed notification</tag>
        <value>Temperature change activity notification</value>
    </ResourceString>
    <ResourceString>
        <tag>Spell_Macro:sym:5901:INTERNAL ISSALG HEAT_CHANGED</tag>
        <value>INTERNAL ISSALG HEAT_CHANGED</value>
    </ResourceString>
    <ResourceString>
        <tag>Spell_Macro:description:5902:Activity Heat Changed notification</tag>
        <value>Temperature change activity notification</value>
    </ResourceString>
    <ResourceString>
        <tag>Spell_Macro:sym:5902:INTERNAL CHGALG HEAT_CHANGED</tag>
        <value>INTERNAL CHGALG HEAT_CHANGED</value>
    </ResourceString>
    <ResourceString>
        <tag>Spell_Macro:description:5903:Activity Heat Changed notification</tag>
        <value>Temperature change activity notification</value>
    </ResourceString>
    <ResourceString>
        <tag>Spell_Macro:sym:5903:INTERNAL MGSALG HEAT_CHANGED</tag>
        <value>INTERNAL MGSALG HEAT_CHANGED</value>
    </ResourceString>
 
5. Save the modified cm.xml file
 
6.  Re-run the RU installer OR run PDM_CONFIGURE manually.  
 
The above approach can be used as template to address issue with other incorrect XML files in the NX_ROOT\data\xml directory.
 
Alternatively, open a Support Case with Broadcom Support for further assistance.
 
As always, we recommend testing all changes in a non-PROD environment first