ALERT: Some images may not load properly within the Knowledge Base Article. If you see a broken image, please right-click and select 'Open image in a new tab'. We apologize for this inconvenience.

Is there a way to block some agents connections to a Enterprise Manager?

book

Article ID: 187111

calendar_today

Updated On:

Products

CA Application Performance Management Agent (APM / Wily / Introscope) CA Application Performance Management (APM / Wily / Introscope) INTROSCOPE DX Application Performance Management

Issue/Introduction

There are some agents which need to be blocked if they try to connect to the MOM or standalone Enterprise Manager. Is there a way to achieve this from APM side?

Cause

Agents that need to be blocked in the EM

Environment

DX APM 10.7.x

Resolution

There is an Enterprise Manager property that will allow to ban the IP addresses from agents. Please follow below steps:

1.- Open the IntroscopeEnterpriseManager.properties file for the Enterprise Manager you would like to block agents
2.- Add the following property:
isengard.server.banned.client.ipaddresses=<Agent1_IP_Address,<Agent2_IP_Address>,<Agent3_IP_Address>

eg:
Agent1 IP Address: 11.157.207.6
Agent2 IP Address: 11.157.207.12
Agent3 IP Address: 11.157.207.13
isengard.server.banned.client.ipaddresses=11.157.207.6,11.157.207.12,11.157.207.13

3.- Save the file
4.- Restart the Enterprise Manager for the changes to take effect

Additional Information


How to block pre-8.x agents from connecting to a MOM / EM.