CA Service Desk ManagerSUPPORT AUTOMATION- SERVERCA Service Desk Manager - Unified Self ServiceCA Service Desk Manager - Mobile ApplicationCA Service Desk Manager - Xtraction
Issue/Introduction
We are using CA SDM 17.2 in conventional mod and configured 1 Primary and 2 Secondary Server. We are trying to integrate the email with SDM. We have followed all the steps from techdocs. Somehow we are not able to integrate mail with CA SDM. Please assist.
Excerpt from Mail_nxd.log: =========================== 2018-01-30 17:04:21:432 ERROR [mailNxdActorSystem-akka.actor.default-dispatcher-8] c.c.S.m.NXJavaMailMailer - The transport is not connected or is dead. javax.mail.AuthenticationFailedException: No authentication mechanisms supported by both server and client at com.sun.mail.smtp.SMTPTransport.authenticate(SMTPTransport.java:847) at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:748) at javax.mail.Service.connect(Service.java:366) at com.ca.ServicePlus.mail.connection.JavaMailSMTPClient.sendMessage(JavaMailSMTPClient.java:248) at com.ca.ServicePlus.mail.connection.JavaMailSMTPClient.sendMail(JavaMailSMTPClient.java:294)
Environment
Release : 17.2/Exchange 2016
Component : SERVICE DESK MANAGER
Cause
At the Mail server end, NTLM has been configured as preferred connection mechanism from JAVA clients. From our Mailer java code, we try to send user name and password when we try to connect. Since the 2 configurations (plain vs NTLM) dont match,
Resolution
# Check the exact authentication mechanism that is configured on Exchange right now. # Work with Exchange administrator to provide an exception be given to SDM's mail account to allow user/password based logon as opposed to say, NTLM.